Redistribution Between EIGRP in Two Different Autonomous Systems

Redistribution Between EIGRP and IGRP in Two Different Autonomous Systems

—————EIGRP 2000————————— EIGRP 1000———-
R-0 ========================= R-1 ======================= R-2

————192.168.10.0/24 ——————– 192.168.20.0/24——-

IP Configuration

R-0 #
lo = 10.0.0.1/24
l1 = 20.0.0.1/24
l2 = 30.0.0.1/24
s0/0 = 192.168.10.1
protokol = eigrp 100

R-1 #
lo = 40.0.0.1/24
l1 = 50.0.0.1/24
l2 = 60.0.0.1/24
s0/0 = 192.168.10.2 << eigrp 100
s0/1 = 192.168.20.2 << eigrp 200

R-2 #
lo = 70.0.0.1
l1 = 80.0.0.1
l2 = 90.0.0.1
s0/0 = 192.168.20.1
protokol = eigrp 200

***********************
Running Configuration Script
***********************

fery@Gaban:~$ su
Password:
su: Authentication failure
Sorry.
fery@Gaban:~$ su
Password:
root@Gaban:/home/fery# telnet 10.8.8.210
Trying 10.8.8.210…
Connected to 10.8.8.210.
Escape character is ‘^]’.

User Access Verification

Password:
R-0>ena
Password:
R-0#sh

R-0#show run
!
hostname R-0
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
ip address 20.0.0.1 255.255.255.0
!
interface Loopback2
ip address 30.0.0.1 255.255.255.0
!
interface FastEthernet0/0
description *** Remote Administration ***
ip address 10.8.8.210 255.255.255.0
!
interface Serial1/0
description *** WAN Connection To R-1 ***
ip address 192.168.10.1 255.255.255.0
!
router eigrp 2000
network 10.0.0.0
network 20.0.0.0
network 30.0.0.0
network 192.168.10.0
no auto-summary
no eigrp log-neighbor-changes
!
logging synchronous
login
end

R-0#
R-0#telnet 192.168.10.2
Trying 192.168.10.2 … Open

User Access Verification

Password:
R-1>ena
Password:

R-1#sh run
!
hostname R-1
no ip domain-lookup
!
interface Loopback0
ip address 40.0.0.1 255.255.255.0
!
interface Loopback1
ip address 50.0.0.1 255.255.255.0
!
interface Loopback2
ip address 60.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-0 ***
ip address 192.168.10.2 255.255.255.0
!
interface Serial0/1
description *** WAN Connection To R-2 ***
ip address 192.168.20.2 255.255.255.0
!
router eigrp 2000
redistribute eigrp 1000 route-map to-eigrp2000
network 40.0.0.0
network 50.0.0.0
network 60.0.0.0
network 192.168.10.0

no auto-summary
no eigrp log-neighbor-changes
!
router eigrp 1000
redistribute eigrp 2000 route-map to-eigrp1000
network 192.168.20.0
no auto-summary
no eigrp log-neighbor-changes
!
route-map to-eigrp2000 deny 10
match tag 2000

!
route-map to-eigrp2000 permit 20
set tag 1000
!
route-map to-eigrp1000 deny 10
match tag 1000

!
route-map to-eigrp1000 permit 20
set tag 2000

!
logging synchronous
login
end

R-1#
R-1#telnet 192.168.20.1
Trying 192.168.20.1 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#sh

R-2#show run
!
hostname R-2
!
no ip domain-lookup
!
interface Loopback0
ip address 70.0.0.1 255.255.255.0
!
interface Loopback1
ip address 80.0.0.1 255.255.255.0
!
interface Loopback2
ip address 90.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-1 ***
ip address 192.168.20.1 255.255.255.0
!
router eigrp 1000
network 70.0.0.0
network 80.0.0.0
network 90.0.0.0
network 192.168.20.0

no auto-summary
no eigrp log-neighbor-changes
!
logging synchronous

R-2#

********************************
Show ip Route Script
********************************

fery@Gaban:~$ su
Password:
root@Gaban:/home/fery# telnet 10.8.8.210
Trying 10.8.8.210…
Connected to 10.8.8.210.
Escape character is ‘^]’.

User Access Verification

Password:
R-0>ena
Password:
R-0#sh ip ro
R-0#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
D 50.0.0.0 [90/2297856] via 192.168.10.2, 00:16:36, Serial1/0
70.0.0.0/24 is subnetted, 1 subnets
D EX 70.0.0.0 [170/2809856] via 192.168.10.2, 00:10:25, Serial1/0
80.0.0.0/24 is subnetted, 1 subnets
D EX 80.0.0.0 [170/2809856] via 192.168.10.2, 00:10:25, Serial1/0
20.0.0.0/24 is subnetted, 1 subnets
C 20.0.0.0 is directly connected, Loopback1
C 192.168.10.0/24 is directly connected, Serial1/0
D EX 192.168.20.0/24 [170/2681856] via 192.168.10.2, 00:10:25, Serial1/0
40.0.0.0/24 is subnetted, 1 subnets
D 40.0.0.0 [90/2297856] via 192.168.10.2, 00:16:36, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, Loopback0
C 10.8.8.0 is directly connected, FastEthernet0/0
90.0.0.0/24 is subnetted, 1 subnets
D EX 90.0.0.0 [170/2809856] via 192.168.10.2, 00:10:25, Serial1/0
60.0.0.0/24 is subnetted, 1 subnets
D 60.0.0.0 [90/2297856] via 192.168.10.2, 00:16:37, Serial1/0
30.0.0.0/24 is subnetted, 1 subnets
C 30.0.0.0 is directly connected, Loopback2
R-0#
R-0#
R-0#telnet 192.168.10.2
Trying 192.168.10.2 … Open

User Access Verification

Password:
R-1>ena
Password:
R-1#sh ip ro
R-1#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
C 50.0.0.0 is directly connected, Loopback1
70.0.0.0/24 is subnetted, 1 subnets
D 70.0.0.0 [90/2297856] via 192.168.20.1, 00:13:18, Serial0/1
80.0.0.0/24 is subnetted, 1 subnets
D 80.0.0.0 [90/2297856] via 192.168.20.1, 00:13:18, Serial0/1
20.0.0.0/24 is subnetted, 1 subnets
D 20.0.0.0 [90/2297856] via 192.168.10.1, 00:15:50, Serial0/0
C 192.168.10.0/24 is directly connected, Serial0/0
C 192.168.20.0/24 is directly connected, Serial0/1
40.0.0.0/24 is subnetted, 1 subnets
C 40.0.0.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 2 subnets
D 10.0.0.0 [90/2297856] via 192.168.10.1, 00:15:50, Serial0/0
D 10.8.8.0 [90/2172416] via 192.168.10.1, 00:15:50, Serial0/0
90.0.0.0/24 is subnetted, 1 subnets
D 90.0.0.0 [90/2297856] via 192.168.20.1, 00:13:19, Serial0/1
60.0.0.0/24 is subnetted, 1 subnets
C 60.0.0.0 is directly connected, Loopback2
30.0.0.0/24 is subnetted, 1 subnets
D 30.0.0.0 [90/2297856] via 192.168.10.1, 00:15:50, Serial0/0
R-1#
R-1#
R-1#telnet 192.168.20.1
Trying 192.168.20.1 … Open

User Access Verification

Password:
R-2>ena
Password:

R-2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
D EX 50.0.0.0 [170/2297856] via 192.168.20.2, 00:09:52, Serial0/0
70.0.0.0/24 is subnetted, 1 subnets
C 70.0.0.0 is directly connected, Loopback0
80.0.0.0/24 is subnetted, 1 subnets
C 80.0.0.0 is directly connected, Loopback1
20.0.0.0/24 is subnetted, 1 subnets
D EX 20.0.0.0 [170/2809856] via 192.168.20.2, 00:09:52, Serial0/0
D EX 192.168.10.0/24 [170/2681856] via 192.168.20.2, 00:09:52, Serial0/0
C 192.168.20.0/24 is directly connected, Serial0/0
40.0.0.0/24 is subnetted, 1 subnets
D EX 40.0.0.0 [170/2297856] via 192.168.20.2, 00:09:52, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
D EX 10.8.8.0 [170/2684416] via 192.168.20.2, 00:09:54, Serial0/0
D EX 10.0.0.0 [170/2809856] via 192.168.20.2, 00:09:54, Serial0/0

90.0.0.0/24 is subnetted, 1 subnets
C 90.0.0.0 is directly connected, Loopback2
60.0.0.0/24 is subnetted, 1 subnets
D EX 60.0.0.0 [170/2297856] via 192.168.20.2, 00:09:54, Serial0/0
30.0.0.0/24 is subnetted, 1 subnets
D EX 30.0.0.0 [170/2809856] via 192.168.20.2, 00:09:54, Serial0/0
R-2#
R-2#
R-2#

Traceroute
**********************************************
R-2#traceroute 10.0.0.1

Type escape sequence to abort.
Tracing the route to 10.0.0.1

1 192.168.20.2 8 msec 32 msec 28 msec
2 192.168.10.1 8 msec * 48 msec
R-2#

Test End to end Connectivity
**********************
R-0#ping 90.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 90.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/20 ms

R-0#telnet 90.0.0.1
Trying 90.0.0.1 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/44/68 ms

R-2#
R-2#show ip eigrp topology 192.168.10.0
IP-EIGRP (AS 1000): Topology entry for 192.168.10.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2681856
Routing Descriptor Blocks:
192.168.20.2 (Serial0/0), from 192.168.20.2, Send flag is 0x0
Composite metric is (2681856/2169856), Route is External
Vector metric:
Minimum bandwidth is 1544 Kbit
Total delay is 40000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 60.0.0.1
AS number of route is 2000
External protocol is EIGRP, external metric is 0
Administrator tag is 0 (0x00000000)
R-2#
R-2# exi

[Connection to 90.0.0.1 closed by foreign host]

R-0#show ip eigrp topology 90.0.0.0
% IP-EIGRP (AS 2000): Route not in topology table
R-0#show ip eigrp topology 192.168.20.0
IP-EIGRP (AS 2000): Topology entry for 192.168.20.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2681856
Routing Descriptor Blocks:
192.168.10.2 (Serial1/0), from 192.168.10.2, Send flag is 0x0
Composite metric is (2681856/2169856), Route is External
Vector metric:
Minimum bandwidth is 1544 Kbit
Total delay is 40000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 60.0.0.1
AS number of route is 1000
External protocol is EIGRP, external metric is 0
Administrator tag is 0 (0x00000000)
R-0#

~ by feryjunaedi on May 29, 2008.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: