Static Routing Protocol Configuration

Static Routing Protocol Configuration

R-0 ===================== R-1 =================== R-2
——-192.168.10.0/24——      —- 192.168.20.0/24—-

R-0 #
lo = 10.0.0.1/24
l1 = 20.0.0.1/24
l2 = 30.0.0.1/24
s0/0 = 192.168.10.1
routing  = static

R-1 #
lo = 40.0.0.1/24
l1 = 50.0.0.1/24
l2 = 60.0.0.1/24
s0/0 = 192.168.10.2 << static to R-0
s0/1 = 192.168.20.2 << static to R-1

R-2 #
lo = 70.0.0.1
l1 = 80.0.0.1
l2 = 90.0.0.1
s0/0 = 192.168.20.1
routing  = static

Running Configuration Script
***********************
root@Gaban:/home/fery# telnet 10.8.8.210
Trying 10.8.8.210…
Connected to 10.8.8.210.
Escape character is ‘^]’.

User Access Verification

Password:
R-0>ena
Password:
R-0#sh
R-0#show run
Building configuration…

Current configuration : 1151 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R-0
!
enable secret 5 $1$RA8s$9k031z6tidMtfwRlIhw6e0
!
ip subnet-zero
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
ip address 20.0.0.1 255.255.255.0
!
interface Loopback2
ip address 30.0.0.1 255.255.255.0
!
interface FastEthernet0/0
description *** Remote Administration ***
ip address 10.8.8.210 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
description *** WAN Connection To R-1 ***
ip address 192.168.10.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.2

ip http server
ip pim bidir-enable
!
!
dial-peer cor custom
!
!
!
!
line con 0
password 7 045D0E1416
logging synchronous
login
line aux 0
line vty 0 4
password 7 15140E1E1D
logging synchronous
login
!
end

R-0#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R-0(config)#exi
R-0#telnet 192.168.10.2
Trying 192.168.10.2 … Open

User Access Verification

Password:
R-1>ena
Password:
R-1#sh
R-1#show run
Building configuration…

Current configuration : 1307 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R-1
!
enable secret 5 $1$GM4Q$PdgBwaCeDIQ1zHcqli/Yi0
!
ip subnet-zero
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
!
interface Loopback0
ip address 40.0.0.1 255.255.255.0
!
interface Loopback1
ip address 50.0.0.1 255.255.255.0
!
interface Loopback2
ip address 60.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-0 ***
ip address 192.168.10.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
description *** WAN Connection To R-2 ***
ip address 192.168.20.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
ip route 10.0.0.0 255.255.255.0 192.168.10.1
ip route 20.0.0.0 255.255.255.0 192.168.10.1
ip route 30.0.0.0 255.255.255.0 192.168.10.1
ip route 70.0.0.0 255.255.255.0 192.168.20.1
ip route 80.0.0.0 255.255.255.0 192.168.20.1
ip route 90.0.0.0 255.255.255.0 192.168.20.1

ip http server
ip pim bidir-enable
!
!
dial-peer cor custom
!
line con 0
password 7 0200014912
logging synchronous
login
line aux 0
line vty 0 4
password 7 045D0E1416
logging synchronous
login
!
end

R-1#c
% Ambiguous command:  “c”
R-1#
R-1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R-1(config)#ex
% Ambiguous command:  “ex”
R-1(config)#exi
R-1#
R-1#
R-1#telnet 192.168.20.1
Trying 192.168.20.1 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#
R-2#
R-2#sh
R-2#show run
Building configuration…

Current configuration : 1018 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R-2
!
enable secret 5 $1$RB/w$9/9tIimd6Mo1kWcvzBcqZ1
!
ip subnet-zero
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
interface Loopback0
ip address 70.0.0.1 255.255.255.0
!
interface Loopback1
ip address 80.0.0.1 255.255.255.0
!
interface Loopback2
ip address 90.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-1 ***
ip address 192.168.20.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.20.2
ip http server
ip pim bidir-enable
!
!
dial-peer cor custom
!
!
line con 0
password 7 094A4B1B00
logging synchronous
login
line aux 0
line vty 0 4
password 7 0200014912
logging synchronous
login
!
end

R-2#
R-2#
R-2#

IP Route Script
************
fery@Gaban:~$ ena
ferybash: ena: command not found
fery@Gaban:~$ su
Password:
root@Gaban:/home/fery# telnet 10.8.8.210
Trying 10.8.8.210…
Connected to 10.8.8.210.
Escape character is ‘^]’.

User Access Verification

Password:
R-0>ena
Password:
Password:
R-0#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is 192.168.10.2 to network 0.0.0.0

20.0.0.0/24 is subnetted, 1 subnets
C       20.0.0.0 is directly connected, Loopback1
C    192.168.10.0/24 is directly connected, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
C       10.0.0.0 is directly connected, Loopback0
C       10.8.8.0 is directly connected, FastEthernet0/0
30.0.0.0/24 is subnetted, 1 subnets
C       30.0.0.0 is directly connected, Loopback2
S*   0.0.0.0/0 [1/0] via 192.168.10.2
R-0#
R-0#
R-0#telnet 192.168.10.2
Trying 192.168.10.2 … Open

User Access Verification

Password:
R-1>ena
Password:
R-1#sh ip ro
R-1#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
C       50.0.0.0 is directly connected, Loopback1
70.0.0.0/24 is subnetted, 1 subnets
S       70.0.0.0 [1/0] via 192.168.20.1
80.0.0.0/24 is subnetted, 1 subnets
S       80.0.0.0 [1/0] via 192.168.20.1
20.0.0.0/24 is subnetted, 1 subnets
S       20.0.0.0 [1/0] via 192.168.10.1
C    192.168.10.0/24 is directly connected, Serial0/0
C    192.168.20.0/24 is directly connected, Serial0/1
40.0.0.0/24 is subnetted, 1 subnets
C       40.0.0.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
S       10.0.0.0 [1/0] via 192.168.10.1
90.0.0.0/24 is subnetted, 1 subnets
S       90.0.0.0 [1/0] via 192.168.20.1
60.0.0.0/24 is subnetted, 1 subnets
C       60.0.0.0 is directly connected, Loopback2
30.0.0.0/24 is subnetted, 1 subnets
S       30.0.0.0 [1/0] via 192.168.10.1
R-1#telnet 192.168.20.1
Trying 192.168.20.1 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#sh
R-2#show ip ro
R-2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is 192.168.20.2 to network 0.0.0.0

70.0.0.0/24 is subnetted, 1 subnets
C       70.0.0.0 is directly connected, Loopback0
80.0.0.0/24 is subnetted, 1 subnets
C       80.0.0.0 is directly connected, Loopback1
C    192.168.20.0/24 is directly connected, Serial0/0
90.0.0.0/24 is subnetted, 1 subnets
C       90.0.0.0 is directly connected, Loopback2
S*   0.0.0.0/0 [1/0] via 192.168.20.2
R-2#

Test End to end Connectivity
**********************
R-2#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/40/56 ms

R-2#
R-2#trace
R-2#traceroute 20.0.0.1

Type escape sequence to abort.
Tracing the route to 20.0.0.1

1 192.168.20.2 24 msec 28 msec 24 msec
2 192.168.10.1 28 msec *  20 msec
R-2#
R-2#telnet 10.0.0.1
Trying 10.0.0.1 … Open

User Access Verification

Password:
R-0>ping 90.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 90.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/24 ms

R-0>trace
R-0>traceroute 90.0.0.1

Type escape sequence to abort.
Tracing the route to 90.0.0.1

1 192.168.10.2 16 msec 12 msec 12 msec
2 192.168.20.1 12 msec *  36 msec
R-0>

~ by feryjunaedi on May 29, 2008.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: