Configure Simple EIGRP Protocol on Cisco Network

Routing EIGRP Configuration
________________________________________________________________________________
ilustration
_______________________________________________________________________________
Under Contraction…

Topology
________________________________________________________________________________

[LAN]—[ R-1 ]—————-[wan]—————-[ R2 ]—[LAN]

R-1 =
eth 2/0 : 192.168.10.1 255.255.255.0
lo 0 : 10.0.0.1 255.255.255.0
lo 1 : 20.0.0.1 255.255.255.0
lo 2 : 30.0.0.1 255.255.255.0

R-2 =
eth 1/0 : 192.168.30.1 255.255.255.0
lo 0 : 40.0.0.1 255.255.255.0
lo 1 : 50.0.0.1 255.255.255.0
lo 2 : 60.0.0.1 255.255.255.0

Routing Protokol = EIGRP

________________________________________________________________________________
Show Running Configuration Script
________________________________________________________________________________

fery@Gaban:~$ telnet 10.8.8.211
Trying 10.8.8.211…
Connected to 10.8.8.211.
Escape character is ‘^]’.

User Access Verification

Password:
R-1>ena
Password:
R-1#sh
R-1#show run

!
hostname R-1
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
ip address 20.0.0.1 255.255.255.0
!
interface Loopback2
ip address 30.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-2 ***
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet1/0
description *** Remote Connection To Router ***
ip address 10.8.8.211 255.255.255.0

interface Ethernet2/0
description *** LAN Connection ***
ip address 192.168.10.1 255.255.255.0
!
router eigrp 200
network 10.0.0.0
network 20.0.0.0
network 30.0.0.0
network 192.168.10.0
network 192.168.20.0

no auto-summary
no eigrp log-neighbor-changes
!
logging synchronous
login
!
end

R-1#
R-1#
R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#sh
R-2#show urn
^
% Invalid input detected at ‘^’ marker.

R-2#sh

R-2#show run
!
hostname R-2
!
interface Loopback0
ip address 40.0.0.1 255.255.255.0
!
interface Loopback1
ip address 50.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-1 ***
ip address 192.168.20.2 255.255.255.0
!
interface Ethernet1/0
description *** LAN Connection R-2 ***
ip address 192.168.30.1 255.255.255.0
!
!
router eigrp 200
network 40.0.0.0
network 50.0.0.0
network 60.0.0.0
network 192.168.20.0
network 192.168.30.0
no auto-summary

no eigrp log-neighbor-changes
!
logging synchronous
login

R-2#
R-2#
________________________________________________________________________________

Show EIGRP Routing Table
________________________________________________________________________________

R-2#
R-2#exi

[Connection to 192.168.20.2 closed by foreign host]
R-1#show ip ro
R-1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
D 50.0.0.0 [90/2297856] via 192.168.20.2, 00:01:00, Serial0/0
D 192.168.30.0/24 [90/2195456] via 192.168.20.2, 00:01:00, Serial0/0
20.0.0.0/24 is subnetted, 1 subnets

C 20.0.0.0 is directly connected, Loopback1
C 192.168.10.0/24 is directly connected, Ethernet2/0
C 192.168.20.0/24 is directly connected, Serial0/0
40.0.0.0/24 is subnetted, 1 subnets
D 40.0.0.0 [90/2297856] via 192.168.20.2, 00:01:00, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, Loopback0
C 10.8.8.0 is directly connected, FastEthernet1/0
30.0.0.0/24 is subnetted, 1 subnets
C 30.0.0.0 is directly connected, Loopback2
R-1#
R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>sh
R-2>show ip ro
R-2>show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
C 50.0.0.0 is directly connected, Loopback1
C 192.168.30.0/24 is directly connected, Ethernet1/0
20.0.0.0/24 is subnetted, 1 subnets
D 20.0.0.0 [90/2297856] via 192.168.20.1, 00:01:05, Serial0/0
D 192.168.10.0/24 [90/2195456] via 192.168.20.1, 00:01:05, Serial0/0

C 192.168.20.0/24 is directly connected, Serial0/0
40.0.0.0/24 is subnetted, 1 subnets
C 40.0.0.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 2 subnets
D 10.0.0.0 [90/2297856] via 192.168.20.1, 00:01:05, Serial0/0
D 10.8.8.0 [90/2172416] via 192.168.20.1, 00:01:05, Serial0/0
30.0.0.0/24 is subnetted, 1 subnets

D 30.0.0.0 [90/2297856] via 192.168.20.1, 00:01:06, Serial0/0
R-2>
R-2>

________________________________________________________________________________

show ip protokol configuration
________________________________________________________________________________
R-1#show ip protocols
Routing Protocol is “eigrp 200”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 200
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
20.0.0.0
30.0.0.0
192.168.10.0
192.168.20.0

Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:16:09
192.168.20.2 90 00:14:41
Distance: internal 90 external 170

R-1#
R-1#
R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>sh
R-2>show ip protocols
Routing Protocol is “eigrp 200”

Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 200
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
40.0.0.0
50.0.0.0
60.0.0.0
192.168.20.0
192.168.30.0

Routing Information Sources:
Gateway Distance Last Update
(this router) 90 00:14:57
192.168.20.1 90 00:14:41
Distance: internal 90 external 170

R-2>
R-2>
________________________________________________________________________________

________________________________________________________________________________
Test End to end Connectivity
________________________________________________________________________________

R-2>
R-2>exi

[Connection to 192.168.20.2 closed by foreign host]
R-1#
R-1#
R-1#ping 40.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/24 ms
R-1#ping 50.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms

R-1#
R-1#ping 192.168.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms

R-1#
R-1#
R-1#telnet 192.168.30.1
Trying 192.168.30.1 … Open

User Access Verification

Password:
R-2>ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/36 ms
R-2>ping 20.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/17/32 ms

R-2>
R-2>ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/14/32 ms

R-2>

~ by feryjunaedi on May 31, 2008.

2 Responses to “Configure Simple EIGRP Protocol on Cisco Network”

  1. hi,

    can you plase tell me ho wcan I really load balance and force EIGRP to take two pathc equally, on epath is one hop away from the border router the other path is two hops away from the other border router. how can i change or lower the costs overt the two hop links to be equal to the one hop path so traffic flows equally by the EIGRP?

    My email is:

    masoodabooali@yahoo.com
    mabooali@irides.com

    thx,

    Masood

  2. hola ,

    tengo una consulta como se puede sumarizar en EIGRP

    gracias

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: