Configure Simple IGRP Protocol on Cisco Network

Routing IGRP Configuration

ilustration
_______________________________________________________________________________
Under Contraction…
Topology
________________________________________________________________________________

[LAN]—[ R-1 ]—————-[wan]—————-[ R2 ]—[LAN]

R-1 =
eth 2/0 : 192.168.10.1 255.255.255.0
lo 0 : 10.0.0.1 255.255.255.0
lo 1 : 20.0.0.1 255.255.255.0
lo 2 : 30.0.0.1 255.255.255.0

R-2 =
eth 1/0 : 192.168.30.1 255.255.255.0
lo 0 : 40.0.0.1 255.255.255.0
lo 1 : 50.0.0.1 255.255.255.0
lo 2 : 60.0.0.1 255.255.255.0

Routing Protokol = IGRP

________________________________________________________________________________
Show Running Configuration Script
________________________________________________________________________________

fery@Gaban:~$ telnet 10.8.8.210
Trying 10.8.8.210…

fery@Gaban:~$ telnet 10.8.8.211
Trying 10.8.8.211…
Connected to 10.8.8.211.
Escape character is ‘^]’.

User Access Verification

Password:
R-1>ena
Password:
R-1#sh
R-1#show run
Building configuration…

Current configuration : 1533 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R-1
!
enable secret 5 $1$rBOL$5r1LpdgntePwTiy/XEW.r.
!
ip subnet-zero
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
ip address 20.0.0.1 255.255.255.0
!
interface Loopback2
ip address 30.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-2 ***
ip address 192.168.20.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
description *** Remote Connection To Router ***
ip address 10.8.8.211 255.255.255.0
duplex auto
speed auto
!
interface Ethernet2/0
description *** LAN Connection ***
ip address 192.168.10.1 255.255.255.0
half-duplex
!
interface Ethernet2/1
no ip address
shutdown
half-duplex
!
interface Ethernet2/2
no ip address
shutdown
half-duplex
!
interface Ethernet2/3
no ip address
shutdown
half-duplex
!
router igrp 100
network 10.0.0.0
network 20.0.0.0
network 30.0.0.0
network 192.168.10.0
network 192.168.20.0

!
ip classless
ip http server
ip pim bidir-enable
!
!
dial-peer cor custom
!
!
line con 0
password 7 03025E191F
logging synchronous
login
line aux 0
line vty 0 4
password 7 0115031642
logging synchronous
login
!
end

R-1#
R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification
Password:
R-2>ena
Password:
R-2#sh
R-2#show run
Building configuration…

Current configuration : 1345 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R-2
!
enable secret 5 $1$D6Dt$O5/wF38GQ7QGt4VM5Poee/
!
ip subnet-zero
!
!
!
call rsvp-sync
!
!
interface Loopback0
ip address 40.0.0.1 255.255.255.0
!
interface Loopback1
ip address 50.0.0.1 255.255.255.0
!
interface Loopback2
no ip address
!
interface Serial0/0
description *** WAN Connection To R-1 ***
ip address 192.168.20.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface Ethernet1/0
description *** LAN Connection R-2 ***
ip address 192.168.30.1 255.255.255.0
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
router igrp 100
network 40.0.0.0
network 50.0.0.0
network 60.0.0.0
network 192.168.20.0
network 192.168.30.0

!
ip classless
ip http server
ip pim bidir-enable
!
!
dial-peer cor custom
!
!
line con 0
password fery
logging synchronous
login
line aux 0
line vty 0 4
password fery
logging synchronous
login
!
end

R-2#
R-2#
R-2#
________________________________________________________________________________

Show IGRP Routing Table
________________________________________________________________________________

R-2#
R-2#exi

[Connection to 192.168.20.2 closed by foreign host]
R-1#
R-1#
R-1#
R-1#
R-1#sh
R-1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

I 50.0.0.0/8 [100/8976] via 192.168.20.2, 00:00:10, Serial0/0
I 192.168.30.0/24 [100/8576] via 192.168.20.2, 00:00:10, Serial0/0

20.0.0.0/24 is subnetted, 1 subnets
C 20.0.0.0 is directly connected, Loopback1
C 192.168.10.0/24 is directly connected, Ethernet2/0
C 192.168.20.0/24 is directly connected, Serial0/0
I 40.0.0.0/8 [100/8976] via 192.168.20.2, 00:00:10, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets

C 10.0.0.0 is directly connected, Loopback0
C 10.8.8.0 is directly connected, FastEthernet1/0
30.0.0.0/24 is subnetted, 1 subnets
C 30.0.0.0 is directly connected, Loopback2
R-1#
R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>sh
R-2>show ip ro
R-2>show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
C 50.0.0.0 is directly connected, Loopback1
C 192.168.30.0/24 is directly connected, Ethernet1/0
I 20.0.0.0/8 [100/8976] via 192.168.20.1, 00:00:18, Serial0/0
I 192.168.10.0/24 [100/8576] via 192.168.20.1, 00:00:18, Serial0/0

C 192.168.20.0/24 is directly connected, Serial0/0
40.0.0.0/24 is subnetted, 1 subnets
C 40.0.0.0 is directly connected, Loopback0
I 10.0.0.0/8 [100/8486] via 192.168.20.1, 00:00:18, Serial0/0
I 30.0.0.0/8 [100/8976] via 192.168.20.1, 00:00:18, Serial0/0

R-2>
R-2>
R-2>
R-2>
________________________________________________________________________________

Test End to end Connectivity
________________________________________________________________________________

R-2>
R-2>exi

[Connection to 192.168.20.2 closed by foreign host]
R-1#
R-1#ping 40.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms
R-1#ping 50.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/20 ms
R-1#ping 192.168.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms

R-1#
R-1#telnet 50.0.0.1
Trying 50.0.0.1 … Open

User Access Verification

Password:
R-2>ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/20 ms
R-2>ping 20.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/17/40 ms
R-2>ping 30.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/20 ms

R-2>
R-2>ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/14/28 ms

R-2>
R-2>

~ by feryjunaedi on May 31, 2008.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: