Configure Simple OSPF Protocol on Cisco Network

Routing OSPF Configuration

ilustration
_______________________________________________________________________________
Under Contraction…

Topology
________________________________________________________________________________

[LAN]—[ R-1 ]———————[wan]———————[ R2 ]—[LAN]

R-1 =
eth 2/0 : 192.168.10.1 255.255.255.0
lo 0 : 10.0.0.1 255.255.255.0
lo 1 : 20.0.0.1 255.255.255.0
lo 2 : 30.0.0.1 255.255.255.0

R-2 =
eth 1/0 : 192.168.30.1 255.255.255.0
lo 0 : 40.0.0.1 255.255.255.0
lo 1 : 50.0.0.1 255.255.255.0
lo 2 : 60.0.0.1 255.255.255.0

Routing Protokol = OSPF
area 0 = R1 to R2
area 1 :
R1 = eth 2/0
lo 0
lo 1
lo 2
area 2 =
R2 = eth 1/0
lo 0
lo 1
lo 2

*lo = Loopback Interface

*eth = Ethernet Interface

*s = Serial Interface
________________________________________________________________________________
Show Running Configuration Script
________________________________________________________________________________

fery@Gaban:~$ su
Password:
root@Gaban:/home/fery# telnet 10.8.8.210
Trying 10.8.8.210…

root@Gaban:/home/fery# telnet 10.8.8.211
Trying 10.8.8.211…
Connected to 10.8.8.211.
Escape character is ‘^]’.

User Access Verification

Password:
R-1>ena
Password:
R-1#show run

!
hostname R-1
!
no ip domain-lookup
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
ip address 20.0.0.1 255.255.255.0
!
interface Loopback2
ip address 30.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-2 ***
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet1/0
description *** Remote Connection To Router ***
ip address 10.8.8.211 255.255.255.0
!
interface Ethernet2/0
description *** LAN Connection ***
ip address 192.168.10.1 255.255.255.0
half-duplex
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.255 area 1
network 20.0.0.0 0.0.0.255 area 1
network 30.0.0.0 0.0.0.255 area 1
network 192.168.20.1 0.0.0.0 area 0

!
!
logging synchronous
login
end

R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#sh

R-2#show run
!
hostname R-2
!
interface Loopback0
ip address 40.0.0.1 255.255.255.0
!
interface Loopback1
ip address 50.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-1 ***
ip address 192.168.20.2 255.255.255.0
!
interface Ethernet1/0
description *** LAN Connection R-2 ***
ip address 192.168.30.1 255.255.255.0
!
router ospf 2
log-adjacency-changes
network 40.0.0.0 0.0.0.255 area 2
network 50.0.0.0 0.0.0.255 area 2
network 60.0.0.1 0.0.0.0 area 2
network 192.168.20.2 0.0.0.0 area 0

!
logging synchronous
login
end

R-2#
________________________________________________________________________________

Show OSPF Routing Table
________________________________________________________________________________

R-1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/32 is subnetted, 1 subnets
O IA 50.0.0.1 [110/65] via 192.168.20.2, 00:05:55, Serial0/0
20.0.0.0/24 is subnetted, 1 subnets
C 20.0.0.0 is directly connected, Loopback1
C 192.168.10.0/24 is directly connected, Ethernet2/0
C 192.168.20.0/24 is directly connected, Serial0/0
40.0.0.0/32 is subnetted, 1 subnets
O IA 40.0.0.1 [110/65] via 192.168.20.2, 00:05:55, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.0.0 is directly connected, Loopback0
C 10.8.8.0 is directly connected, FastEthernet1/0
30.0.0.0/24 is subnetted, 1 subnets
C 30.0.0.0 is directly connected, Loopback2
R-1#
R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>sh
R-2>show ip ro
R-2>show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
C 50.0.0.0 is directly connected, Loopback1
C 192.168.30.0/24 is directly connected, Ethernet1/0
20.0.0.0/32 is subnetted, 1 subnets
O IA 20.0.0.1 [110/65] via 192.168.20.1, 00:07:20, Serial0/0
C 192.168.20.0/24 is directly connected, Serial0/0
40.0.0.0/24 is subnetted, 1 subnets
C 40.0.0.0 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 1 subnets
O IA 10.0.0.1 [110/65] via 192.168.20.1, 00:07:20, Serial0/0
30.0.0.0/32 is subnetted, 1 subnets
O IA 30.0.0.1 [110/65] via 192.168.20.1, 00:07:20, Serial0/0
R-2>
R-2>

________________________________________________________________________________

Test End to end Connectivity
________________________________________________________________________________

R-2>exi

[Connection to 192.168.20.2 closed by foreign host]
R-1#ping 40.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

R-1#ping 50.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/28 ms

R-1#
R-1#telnet 40.0.0.1
Trying 40.0.0.1 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms
R-2#ping 20.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/15/28 ms
R-2#ping 30.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

R-2#wr
Building configuration…
[OK]
R-2#

~ by feryjunaedi on May 31, 2008.

One Response to “Configure Simple OSPF Protocol on Cisco Network”

  1. como sumarizar en ospf

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: