Redistribution Routing Protokol IGRP to OSPF Configuration

Redistribution Routing Protokol IGRP to OSPF Configuration

ilustration
_______________________________________________________________________________
Under Contraction…
________________________________________________________________________________
Topology
________________________________________________________________________________

[LAN]—[ R-1 ]—————-[wan]—————-[ R2 ]—[LAN]

R-1 =
eth 2/0 : 192.168.10.1 255.255.255.0
lo 0 : 10.0.0.1 255.255.255.0
lo 1 : 20.0.0.1 255.255.255.0
lo 2 : 30.0.0.1 255.255.255.0

R-2 =
eth 1/0 : 192.168.30.1 255.255.255.0
lo 0 : 40.0.0.1 255.255.255.0
lo 1 : 50.0.0.1 255.255.255.0
lo 2 : 60.0.0.1 255.255.255.0

Routing Protokol = Redistribution IGRP to OSPF

Protokol IGRP
R-1 = s0/0
eth 2/0
lo 0
lo 1
lo 2
R-2 = s0/0

Protokol OSPF
R-2 = eth 2/0
lo 0
lo 1
lo 2
________________________________________________________________________________
Show Running Configuration Script
________________________________________________________________________________
root@Gaban:/home/fery# telnet 10.8.8.211
Trying 10.8.8.211…
Connected to 10.8.8.211.
Escape character is ‘^]’.

User Access Verification

Password:
R-1>ena
Password:
R-1#sh
R-1#show run

!
hostname R-1
!
no ip domain-lookup
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
ip address 20.0.0.1 255.255.255.0
!
interface Loopback2
ip address 30.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-2 ***
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet1/0
description *** Remote Connection To Router ***
ip address 10.8.8.211 255.255.255.0
!
interface Ethernet2/0
description *** LAN Connection ***
ip address 192.168.10.1 255.255.255.0
half-duplex
!
router igrp 100
network 10.0.0.0
network 20.0.0.0
network 30.0.0.0
network 192.168.10.0
network 192.168.20.0

!
logging synchronous
login
end

R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#sh
R-2#show urn
^
% Invalid input detected at ‘^’ marker.

R-2#sh

R-2#show run
!
hostname R-2
!
!
interface Loopback0
ip address 40.0.0.1 255.255.255.0
!
interface Loopback1
ip address 50.0.0.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-1 ***
ip address 192.168.20.2 255.255.255.0
serial restart-delay 0
!
interface Ethernet1/0
description *** LAN Connection R-2 ***
ip address 192.168.30.1 255.255.255.0
half-duplex
!
router ospf 1
log-adjacency-changes
network 40.0.0.0 0.0.0.255 area 0
network 50.0.0.1 0.0.0.0 area 0
network 60.0.0.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0

!
router igrp 100
redistribute ospf 1 metric 128 20000 255 1 150
network 192.168.20.0

!

R-2#
R-2#
________________________________________________________________________________

Show IGRP Routing Table
________________________________________________________________________________

R-2#
R-2#exi

[Connection to 192.168.20.2 closed by foreign host]
R-1#
R-1#sh
R-1#show ip ro
R-1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

I 50.0.0.0/8 [100/8976] via 192.168.20.2, 00:00:16, Serial0/0
I 192.168.30.0/24 [100/8576] via 192.168.20.2, 00:00:16, Serial0/0
20.0.0.0/24 is subnetted, 1 subnets

C 20.0.0.0 is directly connected, Loopback1
C 192.168.10.0/24 is directly connected, Ethernet2/0
C 192.168.20.0/24 is directly connected, Serial0/0
I 40.0.0.0/8 [100/8976] via 192.168.20.2, 00:00:16, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets

C 10.0.0.0 is directly connected, Loopback0
C 10.8.8.0 is directly connected, FastEthernet1/0
30.0.0.0/24 is subnetted, 1 subnets
C 30.0.0.0 is directly connected, Loopback2
R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

50.0.0.0/24 is subnetted, 1 subnets
C 50.0.0.0 is directly connected, Loopback1
C 192.168.30.0/24 is directly connected, Ethernet1/0
I 20.0.0.0/8 [100/8976] via 192.168.20.1, 00:00:59, Serial0/0
I 192.168.10.0/24 [100/8576] via 192.168.20.1, 00:00:59, Serial0/0

C 192.168.20.0/24 is directly connected, Serial0/0
40.0.0.0/24 is subnetted, 1 subnets
C 40.0.0.0 is directly connected, Loopback0
I 10.0.0.0/8 [100/8486] via 192.168.20.1, 00:00:59, Serial0/0
I 30.0.0.0/8 [100/8976] via 192.168.20.1, 00:00:59, Serial0/0

R-2>
R-2>
________________________________________________________________________________

show ip protokol configuration
________________________________________________________________________________

R-2>exi

[Connection to 192.168.20.2 closed by foreign host]
R-1#
R-1#show ip protocols
Routing Protocol is “igrp 100”
Sending updates every 90 seconds, next due in 10 seconds
Invalid after 270 seconds, hold down 280, flushed after 630
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
IGRP maximum hopcount 100
IGRP maximum metric variance 1
Redistributing: igrp 100
Maximum path: 4
Routing for Networks:
10.0.0.0
20.0.0.0
30.0.0.0
192.168.10.0
192.168.20.0

Routing Information Sources:
Gateway Distance Last Update
192.168.20.2 100 00:00:38
Distance: (default is 100)

R-1#
R-1#
R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

User Access Verification

Password:
R-2>ena
Password:
R-2#show ip protocols
Routing Protocol is “igrp 100”
Sending updates every 90 seconds, next due in 24 seconds
Invalid after 270 seconds, hold down 280, flushed after 630
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
IGRP maximum hopcount 100
IGRP maximum metric variance 1
Redistributing: igrp 100, ospf 1 (internal, external 1 & 2, nssa-external 1 & 2)

Maximum path: 4
Routing for Networks:
192.168.20.0

Routing Information Sources:
Gateway Distance Last Update
192.168.20.1 100 00:01:16
Distance: (default is 100)

Routing Protocol is “ospf 1”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 50.0.0.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
40.0.0.0 0.0.0.255 area 0
50.0.0.1 0.0.0.0 area 0
60.0.0.0 0.0.0.255 area 0
192.168.30.0 0.0.0.255 area 0

Routing Information Sources:
Gateway Distance Last Update
50.0.0.1 110 00:07:53
Distance: (default is 110)

R-2#
R-2#exi

[Connection to 192.168.20.2 closed by foreign host]
R-1#
R-1#
R-1#
R-1#ping 192.168.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

R-1#
R-1#ping 40.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/14/40 ms

R-1#
R-1#ping 50.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/14/44 ms

R-1#
R-1#
R-1#
R-1#ping 192.168.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/24/44 ms

R-1#
R-1#

R-1#telnet 192.168.20.2
Trying 192.168.20.2 … Open

ser Access Verification

Password:
R-2>ena
Password:
R-2#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms
R-2#ping 20.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/16 ms

R-2#ping 30.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms

R-2#
R-2#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/18/48 ms

R-2#
R-2#

~ by feryjunaedi on May 31, 2008.

2 Responses to “Redistribution Routing Protokol IGRP to OSPF Configuration”

  1. mantab man

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: