Basic BGP Configuration on Cisco Network

Basic BGP Configuration

Topology
________________________________________________________________________________

[LAN]—[ R-1 ]—————-[wan]—————-[ R2 ]—[LAN]

R-0 =
– eth 2/0 : 192.168.10.1 255.255.255.0
– lo 0 : 10.10.0.1 255.255.255.0
– lo 1 : 10.10.1.1 255.255.255.0
– lo 2 : 10.10.2.1 255.255.255.0

R-1 =
– eth 1/0 : 192.168.10.2 255.255.255.0
– lo 0 : 20.20.0.1 255.255.255.0
– lo 1 : 20.20.1.1 255.255.255.0
– lo 2 : 20.20.2.1 255.255.255.0

Routing Protokol = BGP
R-0 = AS 1
advertise network =
10.10.0.0 255.255.255.0
10.10.1.0 255.255.255.0
10.10.2.0 255.255.255.0
R-1 = AS 2
advertise network =
20.20.0.0 255.255.255.0
20.20.1.0 255.255.255.0
20.20.2.0 255.255.255.0
________________________________________________________________________________
Show Running Configuration Script
________________________________________________________________________________

fery@Gaban:~$ telnet 10.8.8.210
Trying 10.8.8.210…
Connected to 10.8.8.210.
Escape character is ‘^]’.

User Access Verification

Password:
R-0>ena
Password:
R-0#sh
R-0#show run

!
hostname R-0
!
!
interface Loopback0
ip address 10.10.0.1 255.255.255.0
!
interface Loopback1
ip address 10.10.1.1 255.255.255.0
!
interface Loopback2
ip address 10.10.2.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-1 ***
ip address 192.168.10.1 255.255.255.0
serial restart-delay 0
!
interface FastEthernet1/0
description *** Remote Access LAN ***
ip address 10.8.8.210 255.255.255.0
!
router bgp 1
bgp log-neighbor-changes
network 10.10.0.0 mask 255.255.255.0
network 10.10.1.0 mask 255.255.255.0
network 10.10.2.0 mask 255.255.255.0
neighbor 192.168.10.2 remote-as 2

!
logging synchronous
login
!
end

R-0#
R-0#
R-0#
R-0#
R-0#telnet 192.168.10.2
Trying 192.168.10.2 … Open

User Access Verification

Password:
R-1>ena
Password:
R-1#sh

R-1#show run
!
hostname R-1
!
interface Loopback0
ip address 20.20.0.1 255.255.255.0
!
interface Loopback1
ip address 20.20.1.1 255.255.255.0
!
interface Loopback2
ip address 20.20.2.1 255.255.255.0
!
interface Serial0/0
description *** WAN Connection To R-0 ***
ip address 192.168.10.2 255.255.255.0
!
router bgp 2
bgp log-neighbor-changes
network 20.20.0.0 mask 255.255.255.0
network 20.20.1.0 mask 255.255.255.0
network 20.20.2.0 mask 255.255.255.0
neighbor 192.168.10.1 remote-as 1

!
l
logging synchronous
login
!
end

R-1#

________________________________________________________________________________

Show IP Protokol
________________
________________________________________________________________

R-1#exi

[Connection to 192.168.10.2 closed by foreign host]
R-0#
R-0#show ip protocols
Routing Protocol is “bgp 1”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is enabled
Automatic route summarization is enabled
Neighbor(s):
Address FiltIn FiltOut DistIn DistOut Weight RouteMap
192.168.10.2
Maximum path: 1
Routing for Networks:
Routing Information Sources:
Gateway Distance Last Update
192.168.10.2 20 00:06:19
Distance: external 20 internal 200 local 200

R-0#
R-0#telnet 192.168.10.2
Trying 192.168.10.2 … Open

User Access Verification

Password:
R-1>ena
Password:
R-1#show ip protocols
Routing Protocol is “bgp 2”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is enabled
Automatic route summarization is enabled
Neighbor(s):
Address FiltIn FiltOut DistIn DistOut Weight RouteMap
192.168.10.1
Maximum path: 1
Routing for Networks:
Routing Information Sources:
Gateway Distance Last Update
192.168.10.1 20 00:05:16
Distance: external 20 internal 200 local 200

R-1#
R-1#exi

[Connection to 192.168.10.2 closed by foreign host]
R-0#

________________________________________________________________________________

Show BGP Summary and Routing Table
________________________________________________________________________________

R-0#show ip bgp sum
BGP router identifier 10.10.2.1, local AS number 1
BGP table version is 7, main routing table version 7
6 network entries and 6 paths using 798 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 6/0 prefixes, 6/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.10.2 4 2 14 14 7 0 0 00:09:02 3
R-0#

R-0#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 3 subnets
B 20.20.0.0 [20/0] via 192.168.10.2, 00:07:16
B 20.20.1.0 [20/0] via 192.168.10.2, 00:07:16
B 20.20.2.0 [20/0] via 192.168.10.2, 00:07:16

C 192.168.10.0/24 is directly connected, Serial0/0
10.0.0.0/24 is subnetted, 4 subnets
C 10.10.0.0 is directly connected, Loopback0
C 10.10.1.0 is directly connected, Loopback1
C 10.10.2.0 is directly connected, Loopback2
C 10.8.8.0 is directly connected, FastEthernet1/0
R-0#

R-1#show ip bgp sum
BGP router identifier 20.20.2.1, local AS number 2
BGP table version is 7, main routing table version 7
6 network entries and 6 paths using 798 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 6/0 prefixes, 6/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.10.1 4 1 14 14 7 0 0 00:09:54 3
R-1#
R-1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 3 subnets
C 20.20.0.0 is directly connected, Loopback0
C 20.20.1.0 is directly connected, Loopback1
C 20.20.2.0 is directly connected, Loopback2
C 192.168.10.0/24 is directly connected, Serial0/0
10.0.0.0/24 is subnetted, 3 subnets
B 10.10.0.0 [20/0] via 192.168.10.1, 00:06:17
B 10.10.1.0 [20/0] via 192.168.10.1, 00:06:17
B 10.10.2.0 [20/0] via 192.168.10.1, 00:06:17

R-1#

R-1#ping 10.10.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/16/28 ms

R-1#exi

[Connection to 192.168.10.2 closed by foreign host]
R-0#ping 20.20.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/16 ms
R-0#

~ by feryjunaedi on June 6, 2008.

One Response to “Basic BGP Configuration on Cisco Network”

  1. Hello webmaster
    I would like to share with you a link to your site
    write me here preonrelt@mail.ru

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: