SIMPLE Configuration Cisco GRE Tunnel

SIMPLE Configuration GRE Tunnel

Topology :

Jakarta#show run
!
hostname Jakarta
!
interface Loopback0
description *** LAN Connection ***
ip address 192.168.200.1 255.255.255.0
!
interface Tunnel0
description *** GRE Tunnel From Jakarta To Kalimantan ***
ip address 10.0.0.1 255.255.255.0
tunnel source 192.168.50.1
tunnel destination 192.168.80.1
!
interface Serial0/0
description *** WAN Connection To ISP Jakarta ***
ip address 192.168.50.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.50.2
!
logging synchronous
login
!
end

Jakarta#

************************

Kalimantan#show run
!

hostname Kalimantan
no ip domain-lookup
!
interface Loopback0
description *** LAN Connection ***
ip address 192.168.220.1 255.255.255.0
!

interface Loopback1
description *** LAN Connection ***
ip address 192.168.200.2 255.255.255.0
interface Tunnel0
description *** GRE Tunnel From Kalimantan To Jakarta ***
ip address 10.0.0.2 255.255.255.0
tunnel source 192.168.80.1
tunnel destination 192.168.50.1
!
interface Serial0/0
description *** WAN Connection To ISP Jakarta
ip address 192.168.80.1 255.255.255.0

!
ip route 0.0.0.0 0.0.0.0 192.168.80.2
!
logging synchronous
login
!
end
Kalimantan#

**********************************************

Test Ping Tunnel Interface Kalimantan
Jakarta#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/33/56 ms

Test Traceroute to Tunnel Interface Kalimantan
Jakarta#traceroute 10.0.0.2

Type escape sequence to abort.
Tracing the route to 10.0.0.2

1 10.0.0.2 28 msec 4 msec *
Jakarta#

Test Ping to Tunnel Interface Jakarta
Kalimantan#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/32/52 ms

Test Traceroute to Tunnel Interface Jakarta
Kalimantan#traceroute 10.0.0.1

Type escape sequence to abort.
Tracing the route to 10.0.0.1

1 10.0.0.1 16 msec * 36 msec
Kalimantan#

Show Routing Table
******************
Jakarta#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is 192.168.50.2 to network 0.0.0.0

C 192.168.200.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Tunnel0
C 192.168.50.0/24 is directly connected, Serial0/0
S* 0.0.0.0/0 [1/0] via 192.168.50.2
Jakarta#

Kalimantan#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is 192.168.80.2 to network 0.0.0.0

C 192.168.80.0/24 is directly connected, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Tunnel0
C 192.168.220.0/24 is directly connected, Loopback0
S* 0.0.0.0/0 [1/0] via 192.168.80.2
Kalimantan#

~ by feryjunaedi on August 12, 2008.

4 Responses to “SIMPLE Configuration Cisco GRE Tunnel”

  1. Thank you very much.I have got the basic idea behind GRE tunnel with this example.

  2. Hi,
    Why would you use GRE and not IPsec ?
    Which is the advantage or disadvantage.

    • Hi adrian,

      basically gre being used for MTU purpose,as default in ipsec is using 1500 MTU as default,whereby GRE can be used in a range 1500 above to 9000. It serves to cater all connection that like having issue to access web though it looks like the connection was almost there in browser.

  3. HI Fery,
    Whats the purpose of the second loopback interface on Kalimantan Router? And why does it belong to same network as Jakarta LAN?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: