Basic Configuration NAT Overload

In this Post i try to configure NAT overload using GNS3 Emulator. where is Router R-Gateway directly connected to internet and Router HOST is emulate like single PC Connecting internet using R-Gateway as the internet Gateway. Actualy there’s must be implement VLSM with slash / 30 for connecting to the internet. but for make easy to understand i’m using slash /24 or class C both for LAN and WAN Interface.

here is my topology for simple NAT Overload using GNS3 :

And Here’s the Running Config for the configuration :

R-Gateway#show run
!
hostname R-Gateway
!
!
interface FastEthernet0/0
description *** Remote Connection ***
ip address 10.8.8.211 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Ethernet1/0
description *** LAN Connection ***
ip address 192.168.10.1 255.255.255.0
ip nat inside
half-duplex
!
ip nat pool test 10.8.8.211 10.8.8.211 netmask 255.255.255.0
ip nat inside source list 1 pool test overload

ip classless
ip route 0.0.0.0 0.0.0.0 10.8.8.1
ip http server
ip pim bidir-enable
!
access-list 1 permit 192.168.10.0 0.0.0.255
!
R-Gateway#
R-Gateway#ping http://www.google.com

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.239.61.104, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/110/144 ms

R-Gateway#telnet 192.168.10.2
Trying 192.168.10.2 … Open

User Access Verification

Password:
HOST>ena
Password:
HOST#
HOST#show run
!
hostname HOST
!
interface Ethernet0/0
description *** To WAN Connection ***
ip address 192.168.10.2 255.255.255.0
half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.1
!
HOST#
HOST#ping
Protocol [ip]:
Target IP address: 216.239.61.104   << google ip address
Repeat count [5]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 216.239.61.104, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!
!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!

Success rate is 97 percent (97/100), round-trip min/avg/max = 112/124/180 ms
HOST#

Thanks,

~ by feryjunaedi on September 3, 2008.

One Response to “Basic Configuration NAT Overload”

  1. Extremely Perfect, you are a jemmm.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: