OSPF Multiple Area With Virtual Link

OSPF Multiple Area With Virtual Link

Dari beberapa Internal Routing Protokol yang ada, seperti RIP, IGRP, EIGRP, maka OSPF lah yang cukup rumit dalam pembuatan rule dan implementasinya. karena OSPF adalah routing  Protokol yang Futuristik.

Pemahaman yang mendasar mengenai bagaimana proses OSPF neighborship terbentuk, istilah / terminology yang digunakan seperti Link State Update (LSU), Links State Advertisement (LSA), Link State Database (LSD) dan bagaimana konsep DR / BDR bekerja,  akan sangat membantu sekali dalam melakukan trobleshooting jika terjadi masalah pada jaringan OSPF.

Pada Topologi Lab yang kita bangun kali ini, saya membuat skenario jaringan yang terdiri dari beberapa area, yaitu Area 0 (Backbone) , Area 1 dan Area 2. Secara Default, Setiap Area Harus memilik koneksi langsung ke Area 0 atau Area Backbone.

disini kita memiliki beberapa router, dimana pada R-3 dan R-4 tidak memiliki koneksi langsung ke Area 0, dengan demikian R-3 dan R-4 tidak mendapatkan routing update dari R-2 dan R-1. Solusinya adalah kita akan membuatkan virtual link dari R-2 ke R-3 seolah2x membuat tunnel yang menghubungkan antara area 0 dan area 2  disini kita tampilkan full configuration dari setiap router

note :
– interface loopback nantinya berfungsi sebagai Router-ID
– pada ip route diawali dengan IA << ini adalah ospf inter area
– untuk menguji apakah virtual link bekerja, kita bisa melakukan ping
dari R-4 di area 2  ke R-1 di area 0

Klik ini untuk melihat Topology Network :

Full Configuration :

********************************************************************************
R-1
********************************************************************************
R-1#show run
Building configuration…
!
hostname R-1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
description *** LAN RT-1 ***
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
description *** TO WAN ***
ip address 10.8.8.212 255.255.255.0 secondary
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
!
end

R-1#
R-1#

R-1#show ip protocols
Routing Protocol is “ospf 1”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.20.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
1.1.1.1 0.0.0.0 area 0
192.168.10.0 0.0.0.255 area 0
192.168.20.0 0.0.0.255 area 0
Routing Information Sources:
Gateway         Distance      Last Update
3.3.3.3              110      00:09:06
2.2.2.2              110      00:09:06
Distance: (default is 110)

R-1#

R-1#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet1/0            192.168.20.1    YES manual up                    up
FastEthernet1/1            192.168.10.1    YES manual up                    up
Loopback0                  1.1.1.1         YES manual up                    up
R-1#
R-1#

R-1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 192.168.20.2, 00:09:11, FastEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA    3.3.3.3 [110/3] via 192.168.20.2, 00:09:11, FastEthernet1/0
O IA 192.168.30.0/24 [110/2] via 192.168.20.2, 00:09:11, FastEthernet1/0
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/4] via 192.168.20.2, 00:09:11, FastEthernet1/0
C    192.168.10.0/24 is directly connected, FastEthernet1/1
O IA 192.168.40.0/24 [110/3] via 192.168.20.2, 00:09:11, FastEthernet1/0
C    192.168.20.0/24 is directly connected, FastEthernet1/0
10.0.0.0/24 is subnetted, 1 subnets
C       10.8.8.0 is directly connected, FastEthernet1/1
O IA 192.168.50.0/24 [110/4] via 192.168.20.2, 00:09:12, FastEthernet1/0
R-1#
R-1#

********************************************************************************
R-2
********************************************************************************
R-2#show run
Building configuration…
!
hostname R-2
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
description *** TO RT-1 **
ip address 192.168.20.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
description *** TO RT-3 **
ip address 192.168.30.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
area 1 virtual-link 3.3.3.3
network 2.2.2.2 0.0.0.0 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 1
!
end

R-2#show ip protocols
Routing Protocol is “ospf 1”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 2.2.2.2
It is an area border router
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
2.2.2.2 0.0.0.0 area 0
192.168.20.0 0.0.0.255 area 0
192.168.30.0 0.0.0.255 area 1
Routing Information Sources:
Gateway         Distance      Last Update
3.3.3.3              110      00:10:23
192.168.20.1         110      00:10:23
Distance: (default is 110)

R-2#

R-2#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet1/0            192.168.20.2    YES manual up                    up
FastEthernet1/1            192.168.30.2    YES manual up                    up
Loopback1                  2.2.2.2         YES manual up                    up
R-2#

R-2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/2] via 192.168.20.1, 00:10:38, FastEthernet1/0
2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback1
3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 192.168.30.1, 00:10:48, FastEthernet1/1
C    192.168.30.0/24 is directly connected, FastEthernet1/1
4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/3] via 192.168.30.1, 00:10:38, FastEthernet1/1
O    192.168.10.0/24 [110/2] via 192.168.20.1, 00:10:38, FastEthernet1/0
O IA 192.168.40.0/24 [110/2] via 192.168.30.1, 00:10:38, FastEthernet1/1
C    192.168.20.0/24 is directly connected, FastEthernet1/0
O IA 192.168.50.0/24 [110/3] via 192.168.30.1, 00:10:38, FastEthernet1/1
R-2#

********************************************************************************
RT-3
********************************************************************************
RT-3#show run
Building configuration…
!
hostname RT-3
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
description *** TO RT-2 ***
ip address 192.168.30.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
description *** RO RT-4 ***
ip address 192.168.40.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
area 1 virtual-link 2.2.2.2
network 3.3.3.3 0.0.0.0 area 1
network 192.168.30.0 0.0.0.255 area 1
network 192.168.40.0 0.0.0.255 area 2
!
end

RT-3#
RT-3#
RT-3#

RT-3#show ip protocols
Routing Protocol is “ospf 1”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 3.3.3.3
It is an area border router
Number of areas in this router is 3. 3 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
3.3.3.3 0.0.0.0 area 1
192.168.30.0 0.0.0.255 area 1
192.168.40.0 0.0.0.255 area 2
Routing Information Sources:
Gateway         Distance      Last Update
2.2.2.2              110      00:11:24
4.4.4.4              110      00:11:44
192.168.20.1         110      00:11:24
Distance: (default is 110)

RT-3#
RT-3#

RT-3#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/3] via 192.168.30.2, 00:11:28, FastEthernet1/0
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 192.168.30.2, 00:11:28, FastEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback1
C    192.168.30.0/24 is directly connected, FastEthernet1/0
4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/2] via 192.168.40.2, 00:11:48, FastEthernet1/1
O    192.168.10.0/24 [110/3] via 192.168.30.2, 00:11:28, FastEthernet1/0
C    192.168.40.0/24 is directly connected, FastEthernet1/1
O    192.168.20.0/24 [110/2] via 192.168.30.2, 00:11:28, FastEthernet1/0
O    192.168.50.0/24 [110/2] via 192.168.40.2, 00:11:48, FastEthernet1/1
RT-3#
RT-3#
RT-3#

********************************************************************************
RT-4
********************************************************************************
RT-4#show run
Building configuration…
!
hostname RT-4
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet1/0
description *** TO RT-3 ***
ip address 192.168.40.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 192.168.50.1 255.255.255.0
duplex auto
speed auto
no keepalive
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 2
network 192.168.40.0 0.0.0.255 area 2
network 192.168.50.0 0.0.0.255 area 2
!
end

RT-4#
RT-4#
RT-4#

RT-4#show ip protocols
Routing Protocol is “ospf 1”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 4.4.4.4
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
4.4.4.4 0.0.0.0 area 2
192.168.40.0 0.0.0.255 area 2
192.168.50.0 0.0.0.255 area 2
Routing Information Sources:
Gateway         Distance      Last Update
3.3.3.3              110      00:12:02
Distance: (default is 110)

RT-4#
RT-4#

RT-4#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O IA    1.1.1.1 [110/4] via 192.168.40.1, 00:12:10, FastEthernet1/0
2.0.0.0/32 is subnetted, 1 subnets
O IA    2.2.2.2 [110/3] via 192.168.40.1, 00:12:10, FastEthernet1/0
3.0.0.0/32 is subnetted, 1 subnets
O IA    3.3.3.3 [110/2] via 192.168.40.1, 00:12:30, FastEthernet1/0
O IA 192.168.30.0/24 [110/2] via 192.168.40.1, 00:12:30, FastEthernet1/0
4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback4
O IA 192.168.10.0/24 [110/4] via 192.168.40.1, 00:12:10, FastEthernet1/0
C    192.168.40.0/24 is directly connected, FastEthernet1/0
O IA 192.168.20.0/24 [110/3] via 192.168.40.1, 00:12:10, FastEthernet1/0
C    192.168.50.0/24 is directly connected, FastEthernet1/1
RT-4#
RT-4#

********************************************************************************
********************************************************************************

RT-4#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:00:36    192.168.40.1    FastEthernet1/0
RT-4#

RT-4#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:00:36    192.168.40.1    FastEthernet1/0
RT-4#

RT-3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  –           –        192.168.30.2    OSPF_VL0
2.2.2.2           1   FULL/BDR        00:00:34    192.168.30.2    FastEthernet1/0
4.4.4.4           1   FULL/BDR        00:00:37    192.168.40.2    FastEthernet1/1
RT-3#

R-2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.20.1      1   FULL/DR         00:00:34    192.168.20.1    FastEthernet1/0
3.3.3.3           0   FULL/  –           –        192.168.30.1    OSPF_VL0
3.3.3.3           1   FULL/DR         00:00:31    192.168.30.1    FastEthernet1/1
R-2#

R-1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/BDR        00:00:37    192.168.20.2    FastEthernet1/0
R-1#

~ by feryjunaedi on March 24, 2009.

One Response to “OSPF Multiple Area With Virtual Link”

  1. Om…mau nanya, gmnm c trick / cara mudahnya nentuin area di OSPF dari suatu network topology ? Udah coba2 baca bbrp referensi, tapi masih tetep blm ngerti…Thx

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: